Saturday May 18, 2024

Buggy Sveasoft Alchemy Firmware w/ Linksys WRT54G v1.1
  Posted by: AceBHound on Dec 3rd, 2004 1:12 AM
I just tried out the newly released (Nov 17) Sveasoft Alchemy 6.0rc3 beta firmware on my Linksys WRT54G v1.1 and it wasn't very happy. I was having trouble with FTP using the 6.0rc1 firmware release that was publically available, and decided to fork over the $20 to Sveasoft for a year of firmware releases (allows you to get the development releases). Rather than improve the situation, it made things worse. Perhaps it's just the version of the router I have, because it doesn't seem like anyone else is complaining.

Linksys WRT54G v1.1 Router
Sveasoft Alchemy Pre-5.4a Issues:

-FTP works sometimes, but freezes up on FTP directory listings often.

Sveasoft Alchemy 6.0rc1 Issues:

-FTP works sometimes, but freezes up on FTP directory listings often.

Sveasoft Alchemy 6.0rc3 Issues:

-FTP downloads hang mid-way through FTP session.
-FTP freezes on directory listings.
-Severe problems visiting any websites. Google seemed to work fine. Any other website would not load 99% of the time.

I saw some people talking about an MTU issue with the previous releases of the Alchemy firmware and supposedly 6.0rc3 was supposed to help solve it. I'm not sure if that's part of my problem or not -- I tried loading the firmware 3 seperate times and experienced the same results. I've since loaded the Satori 4.0G firmware from June 2004 and everything seems fine. There goes 3 hours.. but at least it's not something physically wrong with my router =) Looks like I have a few bugs to report..

Reported problem to Sveasoft forums and seems others are having problems as well. It has to do with the MTU settings.

From Sveasoft Forums:
As a work-around in RC3 for PPPoE and PPTP connections add the following line to the rc_firewall nvram var (or paste it into the Command Shell and click Save Firewall) and then reboot.

iptables -I FORWARD -p tcp --tcp-flags SYN,RST SYN -m tcpmss --mss 1461: -j TCPMSS --set-mss 1460

The 1461 and 1460 numbers above are your MTU minus 39 and 40 respectively. If your MTU is not Auto or not set to 1500 please adjust accordingly.

I haven't tried this yet (Satori is working just fine), but perhaps I will give it a try.

View More Techdose Articles